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MineScape 2021 Update 8 
The following section lists new functionality and defect fixes delivered in MineScape 2021 Update 8. 

 

What’s New 

Reserve Generic Mesh 

Generic Mesh has been added to Model Resource, Run Reserves, and Multipart Reserves forms as a reserve 
sample source type. Users can run reserves using a single mesh and decide whether sampling is accumulated or 
unaccumulated.  

  

 

  

Check Thickness Input  
Check Thickness option can now support up to 500 input table rows. The previous version of the Check 
Thickness only supports up to 100 input table rows. 
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     Previous Version (maximum 100 table rows) MineScape 2021 Update 8 (up to 500 table rows) 

Just In-time DTM in StratModel App 
Just In-time DTM option is added to the StratModel app. Users can now use the Just In-time DTM option in the  
Geology product through Rapid Update » Just In-Time DTM under the StratModel ribbon. 
 

 
 

StratModel Ribbon 

 

 
 

Just In-time DTM Form 

 

Specialised Reserve Report 
Specialised Reserve Report has been added to the Reports group. Specialised Reserve Report option can be 
used to generate a user-defined reserve report using a nominated reserve table. The report types are 
‘Summary with Qualities’, ‘Quality by Seam’, and ‘Seam Volumes’. 
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Reserves Ribbon 

 

 

Specialised Reserve Report Form  

 

Examples of Specialised Reserve Report output: 

1. Summary with Qualities 

 

2. Quality by Seam 
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3. Seam Volumes 

 

 

 

Defects Fixed 

#38431 – Fill patterned polygon appeared solid in the PDF file and Print 

Preview mode. 

Problem: A polygon with a fill pattern didn't appear transparent in Print Preview mode and in the PDF file when 
viewport.pagespec (in specs folder) was not available. The viewport object was not properly initialized if 
viewport.pagespec was absent. 

#38962 – The import DXF file doesn’t work properly. 

Problem: The import result layer was not created on the selected design layer when the Support Older Version 
of AutoCAD checkbox was selected. Additionally, the import result layer was created when the Support Older 
Version of AutoCAD checkbox was unselected, however the result was still incorrect. 
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#39137 – Error message displayed after selecting column name in GDB » Data 

» Text 

Problem: Error message displayed after selecting column name in GDB » Data » Text as it was impacted by the  
crash when modifying Data Format Information data grid. 

#40172 – Tolerance issue on Dragline manual tagging point. 

Problem: Error message launched after picking up a tagging point. The point was out of range due to the 
discrepancy between vertices. 

#40230 – Incorrect value for coal tonnage on the Dragline report 

Problem: The report for the Coal using value from column DL_SWREHANDLE instead of DL_COAL.
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MineScape 2021 Update 7 
The following section lists a new functionality and some defect corrections delivered with MineScape 2021 
Update 7. 

 

What’s New 

Mesh Data Export Enhancement 

3D Faces and Single Mesh export type option are added for users to decide how a mesh is exported in the 
AutoCAD format. The default is now 3D Faces which each Mesh Face is exported as a single 3DFace AutoCAD 
object, so that each face is selectable individually. Single Mesh, the previous default, exports mesh as a single 
AutoCAD mesh that has to be exploded first before each face can be selected.  
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Defects Fixed 

#38314 – Unable to export mesh to LandXML from CAD window 

Problem: Exporting mesh to LandXML from CAD window didn't work as it was impacted by the development of 
Mesh to ASCII function. 

#33617 – GDB Hole Report skipping all tables after an invalid table 

Problem: Report stops counting the valid tables in the schema when it hits an invalid table that caused 
truncated report.  

#38379 – Failed to cut mesh at an angle of certain degrees 

Problem: Occasionally, when performing interactive slicing at an angle of certain degree such as 45o, the mesh 
will not be cut.  
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MineScape 2021 Update 6 
The following section lists the new functionality, features and defect corrections delivered with MineScape 
2021 Update 6. 

 

What’s New 

Form Enhancements 
Forms in Block Model, Pit Optimization, Pit Optimization Pro, and Dragline have been updated. 

Block Model 

The appearance and layout of numerous forms have been upgraded and improved to provide a better user 
experience. 

 

Pit Optimization & Pit Optimization Pro 

The Pit Optimization and Pit Optimization Pro forms now use the word price to best represent the actual 
calculation context.   
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Pit Optimization Pro » Costing form now also displays the unit for Production Cost field based on the Cost 
Basis input. Production Cost field shows the cost per tonnes or short tons if the Cost Basis is Mass, and per 
cubic metres if the Cost Basis is Volume. 

 

 

Dragline 

The appearance and layout of numerous forms have been upgraded and improved to provide a better user 
experience. 
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CAD Enhancements 

Data Exchange 

ESRI shape file (SHP) has been added to Import Design Data form as a file type that can be imported into 
MineScape design file. Users can also choose the metadata tag/s to be imported along with the file through the 
Settings section in the form. To display the form, select Data Exchange » Import under the Home ribbon. 

 

Dip and Strike 

 

The Strike Direction options have been added to Plane Dip and Strike form. To display this form, select Dip and 
Strike in Inspect group under the Analyse ribbon. There are two options of direction added: clockwise (+90o) 
and anticlockwise (-90o). 

The following image illustrates the Strike Direction and the result. 

 

 

 

If Strike clockwise to dip direction (+90°) is selected and the dip direction is 315°, then the strike is returned as 
45°. 

If Strike anticlockwise to dip direction (-90°) is selected and the dip direction is 315°, then the strike is returned 
as 225°. 
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Mesh Import and Export File 

MineScape Mesh ASCII file (ASC) has been added to Mesh Import & Mesh Export form as a file type that can 
export from and be imported into MineScape mesh file. Users can also compress mesh file into Zip file. To 
display the form, select File » Import / Export from the Mesh ribbon. 

 

 

 

Move Point 

Move point can now disregard the active Z value. This behaviour is applied when moving point/vertex using 
CAD » Design » Points » Move option and RapidCad. 

 

 



 Release Notes 

 

15 
 

Stratmodel Enhancement 

Check Thickness 

The Drill Holes » Process » Check Thickness option has been added to the Stratmodel ribbon. 

 

The Check Thickness option can be used to check the thickness differences between drill hole intersections and 
surfaces (roof and floor). The value associated with a roof and floor surfaces is compared to the value stored in 
each selected drill hole. 

The Check Thickness form is displayed after selecting Drill Holes » Process » Check Thickness from the 
StratModel ribbon. 

 

The following report file (table and chart) is an example generated by the Check Thickness option. 
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Open Cut Enhancements 

Short Range Planning (SRP) 

The polygon generated by Drape & Project Cut / Fill Polygons button can now be updated or replaced.  This 
polygon can be updated or replaced by selecting <PlanName>_02_CUT or <PlanName>_03_FILL as a write 
design layer. 

 

The following images are examples of updating the polygon on Cut node SRP.   

• Generate SRP Drape & Project Cut polygons.  

 

 

• Import and replace the polygon on <PlanName>_02_CUT layer. 
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• Select Mesh Cut Polygons button. 

 

 

Just In-time DTM 

Create Mesh Surface Definition check box has been added to Just In-time DTM form. Create Mesh Surface 
Definition check box is to create a surface definition (. surface) using the output mesh file. Surface definitions 
are listed in the Definitions » Surfaces folder of the Explorer tab and stored under the surfaces folder of the 
current project. 

 

Dragline 

Dragline can now support up to 4080 vertices on surfaces. In the previous MineScape version, the maximum 
number of vertices allowed on dragline surfaces is 1000.  

Reserves Enhancements 

Reserves Mesh 

The Graphic » Reserves Mesh option has been added to the Reserves ribbon. 

The Graphics » Reserves Mesh option can be used to process the engineering solids mesh and accumulated 
multi-mesh reserves result to get the color-coded mesh for simple pit optimization using coal and overburden 
parameters. The output from Graphics » Reserves Mesh can be used to determine economic area boundaries 
based on Stripping Ratio (SR) value. This value can then be used as a reference/basic for a pit construction. 
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The following table and image are the output mesh generated by the Reserves Mesh option. 

 

 

 

 

Load Form Spec 

Reserves polygon (.res_pol) form spec file can now be easily used in MineScape 2021 by converting and 
importing it. The Convert and Import options have been added to the Model Resource, Run Reserves, and 

Multipart Reserves form menu. To display the menu, left click the  icon on the left top corner of the form, 
and select Convert or Import.  
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Convert 

 
Convert allows users to choose a Source folder and convert all reserves polygon (.res_pol) formspec/s within it 
concurrently. The converted files will be stored in a folder nominated in the Destination field and ready to be 
selected and used through Load Form Specification. 

Import 

 

Import allows users to select a reserves polygon file and immediately load the values from it to the form. 
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Defects Fixed 

#24719 – Drill Hole Top Marker Editing 

Problem: Couldn’t set blast hole marker top colour on Edit Holes form. 

#33617 – Gaps in contour output 

Problem: Small gaps were found when being zoomed in. 

#36309 – Performance issue 

Problem: With many mesh files open, selecting multiple elements took more than 6 seconds and/or led to not-
responding error message.  

#36443 – Missing Mesh names 

Problem: Mesh names did not appear in the properties tab after running Bench Blocks to DTM. 

#36488 – Misfunctioning Enter key  

Problem: In some forms, Enter key didn’t perform the OK button behaviour.  

#36504 – Reconciliation Deficiencies   

Problem: Display Definition and Existing Polygon function on Reconciliation form didn’t work properly. Polygon 
List File was not editable and viewable, and a Form Validation warning appeared when running Reconciliation 
Reserves. 

#36514 – Unavailable Ok and Cancel button on input form   

Problem: OK and Cancel button were not available on the Input form. 

#36534 – Error in Check Surfaces menu  

Problem: In Stratmodel app, performing Check Surfaces menu for larger drill holes showed an error message.  

#36559 – MineScape freezes 

Problem: MineScape freezes after editing text size in Properties editor.  

#36561 – MineScape crash 

Problem: The crash occured after clicking Insert Before in Manual Georeferencing form. 

#36575 – Form won’t update 

Problem: After configuring Display Definition in Mesh Surface Definition form, the name in the form won’t 
update.  

#36660 – Unable to import Surpac file 

Problem: When importing Surpac file into MineScape, module completed with warnings and the layer was 
empty.  
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#36703 – Hole naming issue 

Problem: Hole Name in report file was listed as number with decimal place.  

#36707 –Quantity in Coal Bench Blocks 

Problem: Coal Bench Blocks shows Burden quantity.  

#36724 – Failure in creating database 

Problem: Creating a database and running other admin ribbon operations failed without indication. 

#36761 – Incorrect output of data import 

Problem: Output shows WASULPHUR data in SPE column and WASPENERGY data in SUL column. 

#36896 – Admin options did not work after changing the port for SQL server 

Problem: Cannot run admin options when target SQL Server instance uses a non-default port. 

#36897 – Debug script is visible to users 

Problem: Script log files containing debug/TODO lines were visible to users. 

#36898 – Misbehaviour of Properties and Visual Overrides editor 

Problem: Elements could be selected when Pick option had been disabled, and overridden colour was removed 
although Colour option in Visual Overrides editor remained ticked.     

#36902 – Failed to update Reconciliation reserves grid 

Problem: Reconciliation reserves grid was not updated after changing polygon list. 

#36922 – Create Solid Between Surfaces input required Schema & Model 

Type 

Problem: Create Solid Between Surfaces couldn’t be completed without Schema and Model Type input and 
caused error message.  

#36941 – Gaps found in Triangle Prisms 

Problem: Holes were found in prisms created through StratModel > Prisms > Graphics > Pick Polygon. 

#37014 – Inability to contour mesh 

Problem: Contour was not created after correctly completing the form. 

#37046 – Drill holes partially not imported  

Problem: Some of the drill holes were not imported correctly when the Output Layer Name column was 
mapped.  

#37047 – Fault’s Era and Extent default value   

Problem: Era and Extent values were set to 0 (zero) by default.  
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#37052 – MineScape Crash   

Problem: The crash occurred when opening a table in the Excel app which was not set in the registry.  

#37062 – Minex Grid ASCII Import Issues 

Problem: Separate Quality and Schema functions did not work after importing the ASCII structure dump file. 

#37137 – MineScape Diagnostics Help Issues 

Problem: Help files in MineScape Diagnostics, License Diagnostics, and Server Diagnostics couldn’t be loaded.  

#37186 – Inability to use Design Polygon object to relimit the mesh 

Problem: Design Polygon couldn’t be selected to relimit the mesh.  

#37193 – Overlapping Fields in Expression Surface Definition form 

Problem: Expression Surface Definition form displayed overlapping fields and writing.   

#37259 – MineScape Crash 

Problem: The crash occurred when performing Preview and Print in plot design. 

#37272 – Upside down Pit Optimization visualisation 

Problem:  Pit optimization started at the bottom and worked towards the top. 

#37297 – Inappropriate mesh surface display definition 

Problem: Difference between the picked mesh colour, and the created mesh surface display definition. 

#37331 – Drape did not work properly with points or point string 

Problem: When draping to a mesh group/file or a mesh surface, multiple vertices were created. 

#37336 – Duplicate nodes in Data Exchange 

Problem: Data Exchange Settings form showed duplicate nodes after reloading CAD plugin. 

#37368 – Seams were excluded from cross section 

Problem: Some seams were not shown in cross section. 

#37379 – Empty table after saving changes 

Problem: Lost data in large table file after adding column and saving the changes.  

#37438 – Settings form didn’t launch 

Problem: Settings form in Haulage Drive Road menu didn’t launch.  

#37440 – Some quality values were not listed on Multipart Reserves form 

Problem: The vertical scrollbar was unavailable on the Reserves » Qualities node, and not all quality values 
were listed on the Output To > Quality node. 
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#37481 – The output table was empty when running Intersect Reserves 

option  

Problem: The output table of Intersect Reserves was empty when using list polygon file. 

#37490 – MineScape Crash when cancelling mesh manual georeferencing 

form 

Problem: The crash occurred when cancelling Georeferencing form while selecting the mesh and properties 
editor. 

#37529 – The metadata name contains underscore converted to Pascal case 

Problem: Difference between the input on Find Elements » Add Metadata option and metadata name under 
the metadata list. 

#37545 – No confirmation pop-up message when creating Donut polygon 

Problem: There was no confirmation message and option to  Edit Existing or Create New polygon. 

#37681 – Some qualities value from Output to » Build in Multipart Reserves 

form were not listed on the output table.#37724 – The mesh result from 

Bench Blocks to DTM process was empty 

Problem: The mesh output from Bench Blocks to DTM option was empty. 

#37827 – Auto generated MineScape Crash  

Problem: Unhandled null reference on NotifyMetaAdded. 

#37729 – Loading scenario on Pit Optimization Pro form did not work 

properly 

Problem: Loading scenario couldn’t work properly on Pit Optimization Pro form. 

#37744 – Unable to create reserves report 

Problem: The module couldn’t be successfully completed, and the report was not created when running Run 
Reserves. 

#37756 – MineScape crash when opening specific project 

Problem: The crash occurred when opening project with customized line style or line weight. 

#37770 – The grid spacing delay in viewport properties and plot designer 

Problem: Different grid spacing between grid displayed and the value on the Viewport Properties form. 

#37792 – Unable to Create, Edit, and View Side Definition on Tag Segments 

Problem: Unable to Create, Edit and View side definition on Tag Segment from Open Cut ribbon. 

#37814 – Incorrect sequence of Grid File field and Grid Z Location Value field 

Problem: The Grid File field should be located above the Grid Z Location Value. 
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#37822 – Incorrect units listed on the .dxf file after exporting a Design file to 

.dxf 

Problem: The units listed were incorrect after exporting a Design file into a .dxf file. 

#37824 – Various GDB modules couldn’t run when connecting to SQL server 

with Windows Authentication 

Problem: Various GDB modules couldn’t run when connecting SQL server to Windows Authentication. The 
Windows Authentication passed the GDB username and password as blank. 

#37827 – MineScape Crash 

Problem: Auto-generated MineScape crash 

#37861 – Mismatch of options in Stratmodel » Cross Section in Russian 

version 

Problem: The dropdown list on Cross Section form was not in correct sequence. 

#37869 – Missing Settings section on Walk Through form 

Problem: Settings section was not displayed on Walk Through form. 

#37885 – Copy and Paste not duplicated the element properly 

Problem: The copied element was not pasted on the same position accurately. 

#37900 – The error message appeared when selecting Washability » Product 

Interpretation menu 

Problem: The error message was displayed when selecting Washability » Product Interpretation menu. 

#37935 – Incorrect fields position on Grid Surface Definition form 

Problem: The Grid File field was located below the Grid Value field. 

#37939 – The Minimum Tolerance value was not applied to the Check 

Thickness report 

Problem: The output report file disregards the Minimum Thickness Tolerance value. 

#37948 – Dfstat issue in Suncor 

Problem: Dfstat failures to detect DFserver. 

#37955 – The Element Edit form closed after editing an element when several 

elements are selected 

Problem: When doing element edit on multiple elements, it stopped after clicking OK on first element. 
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#37956 – Error message appeared after running Bench Block from Bench 

Block ribbon 

Problem: Error messages appeared after running Calculate Reserve and Report options. 

#38103 – An error message appeared after running Pit Gridding form 

(customize option) 

Problem: An error message appeared after running Pit Gridding by clicking OK. An error message didn’t occur 
when clicking APPLY. 

#38106 – Warning message didn’t appear when line element was selected for 

Design - Cut and Fill process on SRP 

Problem: A warning message didn’t appear when line element was selected on Cut or Fill process, and the 
feedback message appeared while cut or fill process was running. 

#38134 – Unable to drape element into mesh surface 

Problem: Unable to drape element to mesh surface with original vertices only. 

#38144 – Append > Yes input in Russian version did not work 

Problem: In MineScape Russian version, selecting Yes on the Append options did not append, but overwrote 

the existing.  
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MineScape 2021 Update 5 
 

Security Update 

This release consists only of security updates for MineScape. The update includes defense-in-depth updates to 
improve security-related features. It is imperative that this update be installed to minimize any issues with 
future updates. 
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MineScape 2021 Update 4 
The following section lists the new functionality, features and defect corrections delivered with MineScape 
2021 Update 4. 

 

What’s New 

Data Transfer Enhancements 

The Import From and Export To options have been added to the Explorer tab's right-click menu. To display the 
options, right-click on a design file or layer. 

 
Use the right-click Import From option to import data from an external file format into a design file, for 
example, Datamine Studio, Maptek Vulcan, or AutoCAD DXF or DWG. Use the right-click Export To option to 
export data from a design file to an external file format, for example, Datamine Studio or Maptek Vulcan. 
 
The Include Design File Name check box has been added to the Export Elements to a DXF/DWG File form. 
Select the Include Design File Name check box to include the design file name when naming the output 
AutoCAD layers. Clear the Include Design File Name check box to exclude the design file name from the output 
AutoCAD layer names. 
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The Use MineScape Layer Name check box on the Export Elements to a DXF/DWG File form has also been 
renamed to Use Custom Layer Name. The Export Elements to a DXF/DWG File form is displayed after using the 
right-click Save As option. 

 
The Minex Grid form has been updated and renamed into the Import Minex Grid form. The Import Minex Grid 
form can be used to import an ASCII or Binary ECS formatted Minex file into a MineScape grid and create a 
schema definition. 
 
The Import Minex Grid form is displayed after selecting Import » Minex from the Grids ribbon. 
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The Import Minex Grid form cannot be displayed via the Explorer tab's right-click Import option. The Miner 2 
tabs have also been removed from the right-click Import option for grid files. 

 

 

Slope and Distance Enhancements 

The reported gradient value is now also displayed as a percentage when the current grade units for the project 
are not set to 'Percent'. The current grade units for the project can be set through File » Info or though using 

the  icon on the Properties, Visual Overrides, and Statistics tabs. 
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If a snapping mode is enabled, a circle icon is now used to indicate a point that can be snapped to. 
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Hide Markers on Vertices Enhancements 

The Hide Markers on Vertices check box has been renamed to Hide markers on vertices when more than <n> 
vertices is displayed. 
 
The Hide markers on vertices when more than <n> vertices are displayed check box can be used to disable 
marker display when more than <n> vertices are displayed. If the check box is cleared, the markers will be 
shown normally. The check box is displayed on the Performance node of the Graphics Settings form. 

 

The following image is an example of output using the Hide markers on vertices when more than <n> vertices 
are displayed check box. 
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Drape Elements Enhancements 

The Drape Elements form can now be used to drape elements onto a mesh surface or a mesh file. To drape 
elements onto a mesh surface, select the Surface option followed by the name of the mesh surface. Surfaces 
can also be filtered using the new Mesh entry. 
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To drape elements onto a mesh file, select the Mesh option and nominate the mesh file. The Mesh Group and 

Name can be selected from the available lists or a Mesh ID can be supplied using the  button. efficiencies 

 

 

Resource Classification Enhancements 

The Resource Classification folder has been added to the Explorer tab. The new folder will list all Resource 
Classification specifications for the current project. 
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The Limit and Merge & Clip options have been added under Geology » Resource Classification of the Reserves 
ribbon. 

 

The Limit option can be used to generate boundaries by splitting a nominated polygon that represents a limit 
area or concession boundary against subcrop lines. The resulting boundary will be used to clip the polygons of 
influence. 
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The Merge & Clip option can be used to merge the polygons of influence according to their respective resource 
categories and clip them to the nominated boundaries. 

 

The layout of the form displayed via Resource Classification » Create Resource Classification has been updated 
and improved. The form now uses a tree-control structure instead of vertical tabs. 
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The layout of the form displayed via Resource Classification » Generate Polygons of Influence has been 
updated and improved to use a tree-control structure. 

 

The Resource Classification » Create a Grid option has been renamed to New Grid. The layout of the displayed 
form has also been improved. 
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The layout of the form displayed via Resource Classification » Generate Contour has been updated and 
improved. The form now uses horizontal tabs instead of vertical tabs. 

 

 

Surface Engineering Enhancements 

The process by which boundary polygons are created through the Mining Solids » Solid Boundaries option has 
been improved to greatly reduce unwanted polygons within the resulting output. 
 
In the following example, the boundary polygons on the left right-hand side were generated using the current 
release of MineScape 2021 with unwanted polygons circled. The boundary polygons displayed on the right-
hand side of the example were generated using MineScape 2021 Update 4. 

 

The Mining Solids » Solid Boundaries option is available through the Strip Planning ribbon. 
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The Reconciliation ribbon has been added to the Open Cut ribbon. 

 

The Run Recon option can be used to produce reserve polygons for within, above, and below a mine design 
surface compared to a supplied threshold. 

 

The following image is an example of output generated by the Run Recon option. 

 

The Run Reserves option can be used to generate multi-part reserves for a reconciliation. 
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The following image is an example of output generated by the Run Reserves option. 

 

The Reconciliation folder has been added to the Explorer tab. The Reconciliation folder will list all generated 
reconciliations for the current project. 
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Engineering Optimization Enhancements 

The Pit Optimization Pro » Run option has been added to the Pit Optimization ribbon. The new Pit 
Optimization Pro » Run option can be used to generate an ultimate economic pit shell that takes full advantage 
of models created from MineScape's StratModel app. 
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Washability Enhancements 
The Washability » Compositing » Drill Holes option has been updated. The updated Washability » 
Compositing » Drill Holes option can be used to composite washability data from a wash table file against drill 
holes and generate the associated surface definitions. The Washability » Compositing » Drill Holes option can 
also be used to skip samples or reject intervals that fail various thickness criteria. 

The following image are examples of a table and report produced by the Washability » Compositing » Drill 

Holes option. 

 

 

 

The following image is an example of surfaces generated by the Washability » Compositing » Drill 

Holes option. 

 

The Washability » Compositing » Intervals option has been updated. The updated Washability » Compositing 
» Drill Intervals option can be used to composite washability data from a wash table file against intervals at 
drill hole locations. Once samples have been composited, surface definitions are automatically generated. The 
Washability » Compositing » Intervals option can also be used to skip samples or reject intervals that fail 
various thickness criteria. 



 Release Notes 

 

42 
 

 

The following image are examples of a table and report produced by the Washability » Compositing » 

Intervals option. 

 

 

 

 

Once samples have been composited, surface definitions are automatically generated. The following image is 
an example of surfaces generated by the Washability » Compositing » Intervals option. 
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Defects Fixed 

#23956 - Current drawing attributes change after text edit 

Problem: The current drawing attributes change after editing a text element. 

#31687 - Tooltip incorrectly displayed 

Problem: The line weight tooltip for the Properties Editor is displayed incorrectly. 

#32647 - Tooltip incorrectly displayed 

Problem: Tooltip still displayed onscreen even after exiting the option. 

#33495 - Module feedback incorrectly shown as successful 

Problem: Mesh import feedback incorrectly shown as successful after importing invalid Datamine files. 

#34654 - Thumbnails not created and saved 

Problem: Thumbnail image for point cloud data is not created and saved. 

#35340 - Layer names not included in output 

Problem: Layer names not included in output after selecting Data Exchange » Export » Drill Holes from the 
StratModel ribbon. 

#35350 - Error in stratigraphic model 

Problem: Error in stratigraphic model when there are transgressive seams. 

#35356 - Contour legend does not fit within rectangle 

Problem: The resulting contour legend does not fit within the extents of the nominated rectangle. 

#35379 - Message displayed for offline help 

Problem: MineScape incorrectly displays a message about the offline help being out of date. This issue only 
occurs when offline help has been installed for both MineScape 7 and MineScape 2021. 

#35408 - Scale bar hidden from view 

Problem: The scale bar container is hidden from view when the 'Background' colour setting is being used. 

#35414 - Message displayed for offline help 

Problem: MineScape incorrectly displays a message about the offline help being out of date. This issue only 
occurs when offline help has been installed for both MineScape 7 and MineScape 2021. 

#35497 - MineScape crashes when opening a layer with corrupted elements 

Problem: MineScape crashed when attempting to open a layer with corrupted elements from a design file. 

#35499 - Old report templates being used 

Problem: The reporting options under the StratModel and Reserves ribbons are using report templates with 
the Datamine logo. 
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#35534 - Spec name automatically changes 

Problem: The file name automatically changes to the lith type when editing the spec name. 

#35535 - Missing status prompts 

Problem - Status prompts missing when using Clipboard » Format Painter on the Home ribbon. 

#35551 - Error message displayed 

Problem: An error message is displayed after running Rapid Update » Just In-Time DTM from the Open Cut 
ribbon. This issue only occurs when using a design file that contains a large number of lines. 

#35554 - Admin ribbon is disabled for some users 

Problem: The Admin ribbon is disabled for some GDB users. 

#35567 - Dragline keys not working 

Problem: Dragline hotkeys are not working when pressed. 

#35608 - An error appears when opening form 

Problem: MineScape crashes and an error message is displayed after selecting Reserves » Evaluate » Mining 
Reserves. 

#35636 - Unable to start MineScape 

Problem: Unable to start MineScape. This issue only occurs when using different region settings. 

#35643 - Unable to select Sections node 

Problem: Unable to select the Sections node through Geological Model » Cross Section of the StratModel 
ribbon. This issue only occurs when using MineScape with the Russian language setting. 

#35645 - Error displayed when setting current model 

Problem: An error message is displayed after setting the current model type to 'Grid' through Schema » Set 
Model of the StratModel ribbon. This issue only occurs when using MineScape with the Russian language 
setting. 

#35653 - Statistics issue when database contains many projects 

Problem: Statistics issue when the GDB database contains many projects. 

#35724 - Faults sorting issue 

Problem: Faults with the same era not honouring input order when sorting. 

#35773 - Profile viewport covers previous open viewport 

Problem: When using Development » Extrude Drive from the Underground ribbon, the resulting profile 
viewport is fully displayed and cover the previous open viewport. This issue only occurs when using MineScape 
with the Polish language setting. 
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#35791 - StratModel form issues 

Problem: Unable to use the right-click Pick option in the Design File field. Drop-down list also missing from 
Name field. 

#35811 - Memory consumption issue in Plot Designer 

Problem: Memory consumption issue for table container in Plot Designer. MineScape appears to pause and is 
unresponsive, This issue only occurs after modifying the font size for the table container. 

#35838 - Unable to add custom icons 

Problem: Unable to add custom icons to custom ribbon. 

#35852 - Button missing from Geostatistics form 

Problem: The Generate button is missing from the Edit Study form. This issue only occurs when using 
MineScape with the Russian language setting. 

#35856 - MineScape crashes when running Geostatistics 

Problem: MineScape crashes when running Geostatisitcs. This issue only occurs when using MineScape with 
the Russian language setting. 

#35897 - RapidCAD vertex move issue 

Problem: Unable to successfully select a vertex when multiple elements are displayed under the mouse cursor. 

#35915 - Different font size displayed through print preview 

Problem: Different font size displayed through print preview when using a different DPI setting. The text in the 
PDF file is bigger than in Plot Designer when the Windows DPI setting is greater than 100%. 

#35963 - Performance issue when drawing a line 

Problem: Noticeable lag when drawing a line while a large number of drill hole layers are displayed through the 
CAD window. 

#35993 - Different icon used for custom toolbar 

Problem: Drop-down menu sent to custom toolbar uses a different icon than custom ribbon. 

#36045 - Mesh surface not recognized by block model categorization 

Problem: Mesh surface not recognized by block model categorization. 

#36046 – Unable to use batch functionality 

Problem: Grid krige function does not support batch functionality. 

#36048 – Trace elements table deleted 

Problem: Trace elements table deleted after updating sample advice. 

#36048 – Upgrade popups incorrectly displayed 

Problem: Popup message to upgrade the GDB database appears even after a failed login. 
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#36083 – Dynamic corridor not working 

Problem: Dynamic corridor slicing tool is not create a cutting section. 

#36084 - Cursor does not change 

Problem: Mouse cursor does not change from drag cursor to resize cursor. This issue only occurs after creating 
a measured viewport.  

#36206 – Run reserves form issue 

Problem: The filtered mesh list does not show the proper list after changing the mesh group. 

#36229 - Unable to move vertex 

Problem: Unable to move vertex within CAD window. Issue only occurs when quickly clicking and dragging 
while many layers are loaded. 

#36240 – Unable to move element 

Problem: Unable to move element within CAD window. Issue only occurs when quickly clicking and dragging 
while many layers are loaded. 

#36254 – MineScape crashes after right-clicking in fields 

Problem: MineScape crashes after right-clicking in two different fields. 

#36298 – Drop-down lists incorrectly updates 

Problem: Drop-down lists incorrectly updates before changes are committed.  

#36308 – Temporary cursor remains in CAD window 

Problem: Temporary cursor remains in CAD window after cancelling element move. 

#36309 – Performance issues when opening mesh files 

Problem: Noticeable performance issue when opening a number of mesh files while multiple elements are 
selected through the CAD window. 

#36310 – Performance issue when displaying vertex markers for elements 

Problem: Noticeable performance issue when trying to display vertex markers for elements in the CAD window.  

#36382 – Section surface issue 

Problem: The SURFSECTION module fails when trying to generate surface section lines. 

#36408 – Unable to use latest ODBC drivers 

Problem: Unable to use the latest ODBC drivers (version 18). 

#36416 – Performance issue with mesh import form 

Problem: Noticeable performance issue when trying to open the Mesh Import form. 
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#36431 – Unable to populate fields on mesh import form 

Problem: Unable to populate the point and triangle file lists on the Mesh Import form. 
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MineScape 2021 Update 3 
The following section lists the new functionality, features and defect corrections delivered with MineScape 
2021 Update 3. 

 

What’s New 
CAD 

Improved CAD Forms 

The appearance and layout of numerous forms have been upgraded and improved to provide a better user 
experience. 

 

 

Data Transfer Enhancements 

Design file and mesh file data displayed through the CAD and Paper Window can now be exported to a 
LandXML file. The new Send To » LandXML option can be accessed by right-clicking in either the CAD or Paper 
Window. The resulting XML file is saved under the data folder of your current project. 
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The Add Metadata check box has been added to the AutoCAD DXF/DWG node of the Import Design Data 
form. 

 

When the Add Metadata check box is selected, elements imported into MineScape will include two additional 
metadata fields under the Metadata section of the Properties tab - Autocad Name and Autocad Layer. 

• Autocad Name - The file path for the AutoCAD DXF/DWG file. 

• Autocad Layer - The original layer name from the AutoCAD DXF/DWG file. 

 

Note: The output design file must use the extended design file format in order to apply metadata tags to the 
imported elements. Selecting the Add Metadata check box will increase the time needed to complete the 
import as metadata tags need to be assigned to each element imported. 

The Export a Design File to a DXF File and Export a Design File to a DWG File forms have been updated to 
include the ability to customise the names of the output AutoCAD layers. 
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Select the Use MineScape Layer Name check box to use the MineScape layer name(s) when naming the 
resulting AutoCAD layer(s). Clear the Use MineScape Layer Name check box to assign custom names to the 
resulting AutoCAD layers. In the following example, the custom layer name of 'New_Line' is assigned to the 
output AutoCAD layer. 

 

The Export a Design File to a DXF File and Export a Design File to a DWG File forms are displayed after using 
the right-click Save As » DXF/DWG option on selected layer in a design file. 

 

The Save As option can be accessed by right-clicking on highlighted layers through the Explorer tab or by right-
clicking on highlighted references through the Display tab. 
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Geology 

Improved StratModel Forms 

The appearance and layout of numerous forms have been upgraded and improved to provide a better user 
experience. 

 

Block Model Enhancements 

The Reserves to XPAC and Polygons to XPAC options have been added to the Data Exchange » Export group of 
the Output ribbon. 

 

• Reserves to XPAC - Create a CSV file containing reserving numbers suitable for import into XPAC. 
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• Polygons to XPAC - Create a CSV file containing reserving polygons suitable for import into XPAC. 

 

 

Improved GDB Forms 

The appearance and layout of numerous forms have been upgraded and improved to provide a better user 
experience. 
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Surface Engineering 

Open Cut Enhancements 

The Walkroute Grade Check option has been added to the Graphics section of the Open Cut ribbon. 

 

 

The Walkroute Grade Check option can be used to create station numbers on a selected element. The stations 
numbers are created using a specific distance interval and a slope percentage is generated between the station 
numbers (segmented). The station numbers are created as text elements and saved into the current design file. 
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The Export to Tempo option has been added to the Mining Solids group of the Strip Planning ribbon. 

 

 

The Export to Tempo option can be used to export mining block layers and reserve table files to table files that 
can be used by Minemax Tempo. 
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Updated Settings 

Default Editor for Microsoft Excel Files 

The Default Editor section has been added to the Miscellaneous node of the Options form. This new section 
can be used to configure the default editor to use when opening Microsoft Excel spreadsheet files. Spreadsheet 
files can either be loaded through the Spreadsheet Editor (the default) or Microsoft Excel. 

 

Once the default editor has been set, the  or  button is available within applicable Report File and Excel 

File fields on displayed forms. Click the  button to open a spreadsheet file through the Spreadsheet Editor. 

Click the   button to open the spreadsheet file through Microsoft Excel. 

 

The Options form can be accessed through File » Options or by clicking the  icon on the System toolbar. 
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Hide Markers on Vertices 

The Hide Markers on Point Elements check box has been renamed to Hide Markers on Vertices. The check box 
is displayed on the Performance node of the Graphics Settings form. 

 

The Graphic Settings form can be accessed through clicking the  icon from the Graphics group of the Home 
ribbon. 
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Expiring Licenses 

Warnings for an expiring license are now colour coded. Warnings are displayed through the Start Page and the 
bottom right corner of MineScape. 

 

 

The yellow Maintenance Expired warning message indicates that MineScape will continue to work, however, 
certain apps may not be able to auto-update. For example, if the CAD app is affected, the message will indicate 
that auto-updates will be disabled. If an app other than CAD is affected, the message will indicate that the app 
will cease to work if any updates are installed. The Maintenance Expired warning message is applicable to the 
Permanent license type. 

The red License Expiring warning message will indicate that MineScape will stop working once the expiry date 
is reached. The License Expiring warning message is applicable to the Temporary, Expiring and Subscription-
based license types. 

Note:. In the event that both Permanent and Expiring types are present in the licence file, the Expiring licence 
types take precedence. 
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The Remind Me Later and Dismiss options are available through the list control on the displayed warning 
message. 

 

• Remind Me Later - Hide the warning message for two days, at which point it will be displayed again. 

• Dismiss - Hide the warning message for 30 days. 

Microsoft Windows 11 Support 
MineScape 2021 now supports Microsoft Windows 11. 

 

Custom App Upgrades 
Due to backend changes implemented during the development of MineScape 2021 Update 3, existing custom 
app installations need to be removed and reinstalled using updated installers. The latest custom app installers 
can be downloaded directly from the MineScape software distribution portal. 
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Defects Fixed 

#32981 - Able to access content menu through read-only field 

Problem: Able to access the right-click context menu through the Grid Spec field on the Interval Intersection 
form. Field is read-only and context menu should not be accessible. 

#33305 - RapidCAD purple dot icon changing position 

Problem: RapidCAD's purple dot icon changing position when modifying the rotation point. 

#33498 - Invalid mesh file created 

Problem: An invalid mesh file is created when importing multiple mesh files while the Generate Individual Files 
check box is cleared. 

#33512 - Error when downgrading design file 

Problem: An error occurs when attempting to downgrade a design file that does not contain a layer. 

#34324 - Unable to locate duplicate points 

Problem: Unable to locate and delete duplicate points using Repair Data » Remove Duplicate Points on the 
Design ribbon. 

#34420 - Exception error displayed on start-up 

Problem: An exception error is displayed when starting up MineScape. 

#34443 - Feature articles and news lists are truncated 

Problem: The Feature Articles and News list are truncated when using high display resolutions and DPI (dots 
per inch) settings. 

#34591 - Height cue visual override not working 

Problem: The Out of Bounds Data option is not working as expected when using the Height Cue visual 
override. Data displayed using the Shadow option even when using another available option. 

#34603 - Unable to retrieve column names 

Problem: Unable to retrieve column names through Setup » Quality Parameters on the Quality ribbon. 

#34607 - Incorrect build SQL statement 

Problem: Incorrect build SQL statement. 

#34640 - Unable to open notification 

Problem: Unable to open and view MineScape notification. 

#34720 - Unable to view list of formspecs in subfolder 

Problem: Unable to view list of formspecs in subfolder. 
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#34747 - Hidden elements visible after editing 

Problem: Previously hidden elements is visible after editing an element. 

#34778 - Display definition missing 

Problem: Display Definition column missing from Geological Model » Contour on the StratModel ribbon. 

#34800 - Dragging image does not highlight selected polygon 

Problem: Dragging an image into the CAD window does not highlight the selected polygon. 

#34842 - Hollow fill behaving incorrectly for grids 

Problem: Hollow fill visual override behaving incorrectly for grids. 

#34849 - Unable to use bottom northing and bottom easting 

Problem: Unable to use bottom northing and bottom easting when importing quality data. 

#34850 - Unable to merge resource classification polygon 

Problem: Unable to merge polygons of influence when using horizontal calculation. 

#34866 - Design file to DXF/DWG origin issue 

Problem: Design file to DXF/DWG origin issue. Results don't match MineScape CAD. 

#34895 - Warning message displayed after clicking OK 

Problem: Warning message displayed after clicking OK on the output report file name. 

#35101 - Unable to draw element to layer 

Problem: Unable to draw element after layer opened through Short Range Planning form. 

#35133 - Error appears when saving drill hole 

Problem: An error appears when saving a drill hole through Drill Hole Edit form. 

#35177 - Unable to use colour selection dialog 

Problem: Unable to select a colour from the colour selection dialog on the Contour form. 
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MineScape 2021 Update 2 
The following section lists the new functionality, features and defect corrections delivered with MineScape 
2021 Update 2. 

 

What’s New 
CAD 

Start Page Enhancements 
The selection icons and buttons on the Start Page are now always displayed. 

 
The News section has been added to the Start Page. The News section can be used to access MineScape 
Insider News articles. The News section can also be accessed through the File menu and via the new icon on 
the Quick Access toolbar. 
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Improved CAD Forms 

The appearance and layout of numerous forms have been upgraded and improved to provide a 
better  user experience. 

 

An Apply button has been added to the Create New Layer form. 

 

Explorer Tab Enhancements 

The Explorer tab's right-click Import and Export options have been removed. These option were displayed after 
right-clicking on a design file. The right-click Import option, which was displayed after right-clicking on a layer, 
has been renamed to Transfer Data. 
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Display Tab Enhancements 

View filtering options for the Display tab are now available through a list.  

 

Layers listed through the Display tab can now also be saved and loaded from a display list file using the new  
and  icons.  

 

Click the  icon to save the current list of loaded layers to a display list file (.lst). Display list files are stored 
under the displaydock folder of the current project. Click the  icon to load a previously displayed list of 
layers from a display list file (.lst). Visual overrides applied when a list of loaded layers is saved are retained 
when the display list file is loaded. 
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RapidCAD Enhancements 

The Delta XYZ option has been added to  RapidCAD’s Quick Input Box list. The Delta XYZ can be used to 
determine specific delta X, Y, or Z distance values from the previous point to a nominated point or line 
segment. 

 

A custom Z value can now be applied when inserting vertices through the RapidCAD tool. 

 

Warning for Hidden Write Layer 

A warning message is now displayed through the Feedback tab when attempting to create an element within 
the current write design layer that has been hidden from view. 
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New Cubic Spline Tool 

The Cubic Spline option has been added to the Draw group of the Home ribbon. The Draw Cubic Spline icon 
has also been added to the Design toolbar. 

 

 

The Cubic Spline option can be used to create a smoothed curve that passes through a set of predefined points 
within the CAD window. A single curved line can contain up to 4,094 points. The element is assigned the 'LINES' 
object class and created using the default attributes. 

In the following example, the green element represents the position of the predefined points with the yellow 
element representing the resulting smooth curved line. 

 

Copy and Paste Enhancements 

The Clipboard » Copy and Paste options on the Home ribbon now support the ability to copy and paste on drill 
hole, poly3D, and fault objects. 
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Bird’s-Eye Window Enhancements 
The Birds-Eye option on the View and Slicing ribbons is now a toggle option that can be used to hide and 
display a bird’s-eye window for the current on CAD Window.  

 

 

Placement options are also available underneath the Birds-Eye option. 

 

New Remove Option for Dynamic Slicing 

The Remove option has been added to the Dynamic Slicing group of the Slicing ribbon. The Remove option can 
be used to remove a loaded slice plane from the CAD window. Select the slice plane to remove from the 
displayed list or select Remove All to remove all loaded slice planes. 
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New Height Cue Colour Palette 

The 'Pastel2 Colours' entry added to the Height Cue dialog. The Height Cue dialog is displayed when applying 
height cue colouring through the Visual Overrides tab. 

 

Mesh Enhancements 

The Create Surface Definition check box has been added to the MineScape Triangulation node of the Mesh 
Export form. Select the Create Surface Definition check box to create a triangle surface definition when 
exporting a mesh file to the legacy triangulation format. The resulting surface definition is named after the 
output triangulation file. 
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A prompt whether to create a surface definition is also displayed when using the Explorer tab’s right-click 
Convert To » Triangulation option. Surfaces are listed under the Definitions » Surfaces folder of the Explorer 
tab. 

  

 

 

The Surface Mesh » Expand option on the Mesh ribbon can now expand or shrink an existing mesh file by a 
nominated distance. Enter a positive value to expand an existing surface mesh, and a negative value to shrink 
the surface mesh.  

 

In the following example, the original mesh file along with the expanded and shrunken mesh files are displayed. 
The original mesh file is coloured red while the expanded mesh is coloured blue and the shrunken mesh yellow. 
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The Surface Mesh » Register option on the Mesh ribbon now displays a confirmation prompt after selecting 
the elements to register from the CAD window Select Edit Existing to update the Z-values of the nominated 
elements. Select Create New to create new elements within the current write layer. 

 

Data Exchange Enhancements 

 

The  Data Exchange » Import option now displays the Import Design Data form. The Import Design Data form 
can be used to import data from an external source into a MineScape design file. 
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The Data Exchange » Export option now displays the Export Design Data form. The Export Design Data form 
can be used to export data from a MineScape design file to an external file. 

 

Custom Ribbon Enhancements 

The Explode to My Ribbon option has been added to the right-click customisation options. Some ribbons 
within MineScape contain a list of parent and child options that are accessible after clicking on the arrow 
control under the parent option name. An example of this functionality is the Convert group of 
the Design ribbon which contains two parent options(To Polygons and Explode Text) with nested child options. 
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In previous versions, right-clicking on the To Polygons option and selecting Add Option to My Ribbon would 
result in the To Polygons option and all options underneath it (To Lines, To Points, To Object Definition, 
and Sheet Spec to Layer)  being added to the custom ribbon as shown below. 

 

Expanding the list and right-clicking on child option before selecting Add Option to My Ribbon would add that 
specific option to the custom ribbon. In the following example, the Add Option to My Ribbon option was 
accessed by right-clicking on the To Points option. 

 

The new Explode to My Ribbon option can be used to add the contents of a nominated parent-child list as 
separate options within the custom ribbon. In the following example, right-clicking on the To Polygons option 
and selecting Explode to My Ribbon would result in all options in the To Polygons list being added to the 
custom ribbon as separate options. 

 

Multiple custom ribbons and toolbars can now be deleted through the Customise from. Press and hold 
the Shift or Ctrl key while left-clicking to select multiple entries before pressing the Delete button. 
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Plot Designer Enhancements 

The Plot Designer app now supports the ability to define and use custom plotting variables. Plotting variables 
are now also grouped into two categories - local and global.  

 

 

A local variable refers to plotting variables that are only available to a single plot design file or template, 
whereas a global variable is available to all plot design files and templates within the current project. Local 
plotting variables are defined through the Variables » Local option and global variables 
through Variables » Global. 
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Table Editor Enhancements 

The Import and Export options have been added to the Table Editor ribbon. 

 

Select the Import option to import the contents of a nominated Datamine Studio RM database into a 
MineScape table file. Select the Export option to export the contents of a MineScape table file to Datamine. 
The import and export functionality originally under the Data Exchange » Import and Export options of the 
Home ribbon. 

 

Geology 

StratModel Enhancements 

The Inclined Model and Hole Adjustment Settings section has been added to the Table node of StratModel 
Manage. This new section now allows StratModel to support resource seams that are  heavily inclined with 
non-vertical drill holes. 
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The Draw Schema button added to StratModel Manager. Click the Draw Schema button to draw the current 
stratigraphic schema to a nominated design file layer. 

  

The Ignore Lines Both Lithology and Unit Are Empty  check box has been added to the Import Drill Holes form. 
Select this check box to ignore lines within the input file that have no associated interval and lithology values, 
i.e., values are blank or missing. Clearing this check box will result in blank 'Not logged' records being created 
within the drill holes for each line that has no associated interval and lithology values. 

 

The Import Drill Holes form is displayed after selecting Data Exchange » Import  » Drill Holes from ASCII from 
the StratModel ribbon. 
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The Drill Holes Lithology option has been added to the Data Exchange » Import  group of the StratModel 
ribbon.  

 

The Drill Holes Lithology option can be used to update the lithology values for existing drill holes that already 
have intervals. The lithology values are imported from a nominated ASCII file and merged into the existing drill 
hole objects that have missing lithology logs. 
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The View Table has been added to the Build node of the Washtable & Import form. Click the View Table 
button to view the resulting wash table file once it has been created. 

 
The Washtable & Import form is displayed after selecting Create » Washtable & Import from the Washability 
ribbon. 
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Surface Engineering 

Bench Blocks Enhancements 

A stratigraphic schema AND model type can now be selected when using the Use Surfaces option to create the 
base of the bench solid. When using a Schema, only the surfaces defined within the chosen schema are listed 
through the Surface Name list. If a Schema is not selected, the Surface Name list will contain all surfaces for 
the current project. 

 

The Create Bench form is displayed after selecting Create from the Bench Blocks ribbon. 

 

The Merge DTM option on the Bench Blocks ribbon has been renamed to Bench Blocks to DTM. 
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Dragline Enhancements 

The 1 through 6 keys along the top row of the keyboard are now used to run Dragline-specific commands 
instead of quickly switching between available apps. A notification message is displayed through 
the Feedback tab when the Dragline app is active. 

 

 

UG Engineering 

UG Survey Enhancements 

The UG Survey app now supports the use of  Microsoft SQL Server databases. 

The appearance and layout of numerous forms have been upgraded and improved to provide a 
better  user experience. 
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The Setup » Run and Setup » Admin » Survey Login options on the UG Survey ribbon now support database 
from all ODBC data sources. 

 

The New Database option has been added to the UG Survey ribbon. Select the New Database option to create 
new UG Survey database. Databases can now be created without having to load the GDB app when wanting to 
use  Microsoft SQL Server. 
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The Survey Login and  Survey Logout option have  been added to the UG Survey ribbon. The Survey Login 
option can be used to connect to an existing database, while the Survey Logout option can be used to 
disconnect from the current database. 
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The Add Survey Schema to Existing Database option has been added to  the  UG Survey ribbon. The Add 
Survey Schema to Existing Database option can be used to connect to an existing database. 

 

 

The Attributes option on the UG Survey ribbon has been renamed to Graphical Attributes. 
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Defects Fixed 

#25582 - Unable to open shape file 

Problem : Unable to open shape files listed under the MINSITE folder. The "Shape file {name} incomplete. 
Ensure that {name}.shp, {name.}.shx, and {name}.dbf are available." error message is displayed. 

#25994 - Viewport borders missing from Plot Designer 

Problem - Viewport borders are missing after sending content from CAD window to Plot Designer. Issue occurs 
when the CAD window contains multiple viewports. 

#30797 –Section graphics issues 

Problem : Overlapping header in output GDB section graphics. 2D graphics header is also not aligned correctly. 

#31845 - Code Editor not saved to session file 

Problem : The Code Editor tab is not loaded correctly after reloading a project from a session file. The last open 
document should be displayed. 

#32149 - Table mappings reset after changing preview size 

Problem : Table mappings for Washability's Import CSV form resets after changing the Preview Size value. 

#32207 – “Invalid Field” warning message displayed 

Problem : The “Invalid Field” warning message is displayed. This issue only occurs when using a long file or 
folder path. 

#32580 - Selected container ignored when using Link option 

Problem : Currently selected container is ignored when using the Link option. 

#32588 - Cannot display 2D graphics 

Problem : Cannot displayed 2D graphics through GDB when using specific data. 

#32603 - Fatal errors issued when all validation set to warning 

Problem : Fatal errors are issued when all validation settings are set to 'Warning'. 

#32955 – Incorrect option label 

Problem :  Incorrect option label displayed through right-click history menu. 

#32957 - Form resize issue 

Problem : Form incorrectly resized and is too large. 

#32978 - Duplicate mesh folder under Bench Blocks scenario 

Problem : Duplicate Mesh folder displayed under the Bench Blocks scenario after restarting the project. 

#32985 - Error when creating table 

Problem: Error when creating a table through the Modify Schema form. 
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#33133 - Mesh file deleted after renaming 

Problem : Mesh file is deleted after renaming the file. Issue only occurs when the file is renamed to use the 
name of another existing mesh file. 

#33146 - Unable to run option from Where's Is My Option? form 

Problem : Unable to run Import Drill Holes from ASCII option from the Where's My Option? form. 

#33322 – Cannot import database roles 

Problem : Unable to correctly import database roles from SQL server backup file. 

#33404 – MineScape crashes 

Problem : MineScape crashes when the same value is assigned to the Name and Group metadata tags for a 
mesh file. This issue only occurs while the mesh file was selected through the Properties tab. 

#33422 – Multiple tabs highlighted 

Problem : Multiple tabs highlighted after rearranging CAD windows. 

#33424 - Unable to search mesh folder 

Problem : The Explorer tab's search functionality is not available to the Mesh folder. 

#33487 - Extra column displayed 

Problem : An extra column is displayed at the end of the data grid for some forms. 

#33497 – Wrong file opened after import 

Problem : The wrong mesh file is displayed after completing import. 

#33494 - Mesh file incorrectly deleted 

Problem : Mesh file is incorrectly deleted when both the Generate Individual Files and Overwrite check boxes 
have been selected. 

#33500 - Form resize issue 

Problem : Form incorrectly resized and is too large after using Row » Fill Down. 

#33504 - Surface repair option fails  

Problem : Incorrect output produced when using Surface Mesh » Fill Holes. 

#33505 - Textures broken when applied to multi-mesh output 

Problem : Textures broken when applied to multi-mesh output. 

#33525 - Form does not retain values 

Problem : Previously entered values are not retained after reopening the form. 
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#33526 - Error when using a boundary polygon with many vertices 

Problem : Solid Mesh »  Between Surfaces produces an error when using a boundary polygon with many 
vertices (1,000+). 

#33552 - Restoring formspec displays incorrect fields 

Problem : Incorrect fields display after restoring a formspec for a form that uses a tree-control layout. 

#33576 - Expanded mesh does not follow input mesh 

Problem : The Z level of the expanded mesh file does not follow the input mesh. 

#33599 - Empty error message 

Problem : An empty error message is displayed when attempting to run reserves using a solid mesh that is 
currently open. 

#33615 - Mesh data not loaded from saved plot 

Problem: Mesh data not loaded after loading plot designer file. 

#33681 - Delete key incorrectly deletes element 

Problem : Element incorrectly deleted after pressing the Delete while using RapidCAD to delete vertices. Issue 
occurs after quickly  moving from one vertex to another. 

#33731 - Unable to use an existing base point 

Problem : Unable to select an existing base points using Base Points » Delete. 

#33752 - Duplicate element created 

Problem: A duplicate element is created after using Highwall Ramps » Tag Segments or Manage Strips » 
Rename. 

#33777 - RapidCAD extend/reduce line not working in rotated view 

Problem : RapidCAD's extend/reduce line functionality does not work as expected when using a specific 
rotation or view. 

#33816 - Form resize issue 

Problem : Form incorrectly resized and is too large after using Row » Fill Down. 

#33819 - Form resize issue 

Problem : Form incorrectly resized and is too large after using Row » Fill Down. 

#33854 - Drop-down field changes to an input field after clearing formspec 

Problem : Drop-down field for Washability » Import changes to an input field after clearing formspec. 

#33868 - Form resize issue 

Problem : Form incorrectly resized and is too large after moving form to a different monitor. 
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#33924 - Cannot enable/disable intervals and surface lists 

Problem : Cannot enable or disable the intervals and surface lists on Geological Model » Cross Section when 
All Intervals or All Surfaces selected. 

#33934 - Form issues 

Problem : Unable to view measure name through Orthogonal Measure » Edit or View. Two Left fields 
displayed under the Measurements tab.  

#33947 - Overlapping popups on Start Page 

Problem : Overlapping popups on Start Page. Popup menu does not close after closing dialog window. 

#33957 - Error message displayed when creating a basepoint 

Problem : The "New point {x} already exists" error message is displayed when creating a basepoint containing 
an underscore character (_) in its name. 

#33958 - Unable to run Resgraphics 

Problem : Unable to run Graphics » Reserve Graphics without UCB file in MINSITE folder. 

#33976 – Unable to find batter block 

Problem : Unable to find batter block when using Graphics » Reserve Graphics. 

#33983 - Form resize issue 

Problem : Form incorrectly resized and is too large after using Row » Fill Down. 

#33991 - Menus missing from Spreadsheet Editor ribbon 

Problem : Menus are missing from the Spreadsheet Editor ribbon. This issue only occurs after opening a 
spreadsheet that uses a font different from MineScape. 

#33998 - MineScape crashes when using invalid project root path 

Problem : MineScape crashes when an invalid project root path. 

#34000 - Only able to nominate one copy direction 

Problem : Only able to nominate one direction when using Copy » Parallel. 

#34037 - Form fields truncated  

Problem : Field names on some GDB forms are truncated. 

#34045 - Form fields truncated 

Problem : Field names on the Just In-Time DTM form are truncated. 

#34060 - Form is truncated 

Problem : The Load Formspec form is truncated after the Advanced option is expanded. 
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#34077 - Values missing from closure report 

Problem : Values, such as final back, final stand, and date, are missing from the report produced through 
Measure » Close. 

#34080 - Empty error message when running reserves 

Problem : An empty error message is displayed when running reserves. 

#34090 - Mouse cursor position used instead of tentative point location 

Problem : Current mouse cursor position is used instead of tentative point location. This issue only occurs when 
RapidCAD's input dialog has been locked. 

#34127 - Error when running reserves 

Problem : An exception error is displayed when attempting to run reserves with multiple meshes. 

#34135 - Unable to delete trend surface 

Problem : Unable to delete trend surfaces through the Conformable node of StratModel Manager. 

#34138 -Report truncated 

Problem : The resulting drill hole statistics report is truncated. 

#34167 - Mesh attributes ignored 

Problem : Mesh attributes, such as colour, transparency, and texture, are ignored and not applied to the output 
mesh. 

#34169 - Form is truncated 

Problem : The mesh colour selection dialog is truncated. 

#34175 - MineScape crashes 

Problem : MineScape crashes after clicking on a reference through the Display tab. Issue only occurs after 
applying a visual override. 

#34228 – Custom toolbar disappears 

Problem : Custom toolbar disappears after switching between available apps. 

#34232 - MineScape crashes 

Problem : MineScape crashes when trying to define a new coal template spec for a new database project. 

#34233 – Unable to convert polygon 

Problem : Unable to convert a design polygon to a normal polygon using Convert » To Polygons. 

#34238 – Extra column displayed 

Problem : An extra column is displayed at the end of the data grid for some UG Survey forms. 
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#34281 – MineScape crashes 

Problem : MineScape crashes when using the Import Leica form through UG Survey. 

#34286 – MineScape crashes 

Problem : MineScape crashes after adding a drop-down icon to a custom ribbon. 

#34299 - Form is truncated 

Problem : A number of GDB forms are truncated. 

#34328 – Incorrect option label 

Problem : Incorrect option label displayed through right-click history menu. 

#34329 – Unable to edit base point 

Problem : Unable to edit base point when surveyor set to ‘None’. 

#34332 – Long delay when editing elements colour 

Problem : Long delay when editing an element’s colour through the Properties Editor. 

#34348 – Vertices not shown in some cases 

Problem : Gray vertices are not shown when the mouse 
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MineScape 2021 Update 1 
The following section lists the new functionality, features and defect corrections delivered with MineScape 
2021 Update 1. 

 

What’s New 

RapidCAD Performance Improvements 
Improved performance when editing elements while the Properties Editor is displayed. 

 

Start Page Enhancements 
Improved the loading of components for the MineScape Start Page. A status message is now also displayed 
when project thumbnails are being retrieved. 

 

Rapid Reserver Rebrand 
The Open Cut app’s Rapid Reserver ribbon has been renamed to Bench Blocks. 

 

 

New Mesh Enhancements 
Mesh functionality has been improved to now allow the importing of up to 100,000 files at one time. Multiple 
files can now be combined into a single file when using the Multiple Files option on the Mesh Import form. 

 



 Release Notes 

 

89 
 

Clearing the Generate Individual Files check box while using the Multiple Files option will now produce a single 
multi-mesh file using all supported import files found under the nominated folder. Select the Generate 
Individual Files check box to create an individual mesh file for each import file found under the nominated 
folder. 

The Surface Mesh » Create Surface option now supports the use of multiple boundary polygons when creating 
mesh surfaces within MineScape 2021. The Draw Polygons check box has also been added to the Create 
Surface form. 

 

Select the Draw Polygons check box to pick the required boundary polygons directly from the CAD window. 
Clear the Draw Polygons check box to interactively draw the boundary polygons within the CAD window after 
completing the Create Surface form. 

In the following example, the required boundary polygons (highlighted in green) have been selected directly 
from the CAD window. 
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The Validate & Repair option has been moved from the Edit group  to the File group of the Mesh ribbon. 

 

New Graphics Settings 

 

The Show Vertices When Drawing Element check box has been added to the RapidCAD node of the Graphics 
Settings form. The Show Vertices When Drawing Element check box can be used to display the vertices for 
new elements as they are being created within the CAD window. Vertices within the new element are displayed 
as grey dots. 

 



 Release Notes 

 

91 
 

The Show Vertices for Nearby Elements When Drawing check box has been added to the RapidCAD node of 
the Graphics Settings form. The Show Vertices for Nearby Elements When Drawing check box can be used to 
display the vertices for nearby elements when creating an element within the CAD window. Vertices within a 
nearby element are displayed as grey dots. If multiple elements are near the mouse cursor, press the N key to 
cycle through the elements. 

 

The  Show Vertices When Drawing Element and Show Vertices for Nearby Elements When Drawing check 
boxes are selected by default after installing MineScape 2021 Update 1. 

 

New Help Navigation Icons 
Navigation and print icons are now displayed at the top of each help topic. 

 

Click the  and  icons to go backwards and forwards through your help browsing history for the current 

MineScape session. Click the  icon to print the current help topic. 

• Offline Help  - A new MineScape 2021 offline help installation is required to access the updated hep 
files for MineScape 2021 Update 1. A new copy of the MineScape 2021 offline help installer has been 
uploaded to the MineScape software distribution portal. An existing MineScape 2021 help installation 
must be removed prior to installing the updated MineScape 2021 help.  

• Online Help - Content stored on the official MineScape help server is updated automatically to reflect 
the changes introduced through MineScape 2021 Update 1. 
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Defects Fixed 

#30023 – Split button tooltips and flashing custom toolbar 

Problem: Incorrect tooltip for split buttons on custom toolbar. Flashing custom toolbar from other document 
types. 

#31612 – Unable to select element near the viewport border 

Problem: Unable to select an element that is positioned near the viewport border. 

#31710 - Error validation for Remove Spike and Remove Embayed Sections 

forms 

Problem: A generic data box that allowed non-numeric values was used for the displayed forms. 

#31819 - Selecting a mesh requires two mouse clicks 

Problem: The action was using AskID when selecting mesh files. By default, AskID behaviour requires a double-
click of the mouse. 

# 31963 – Save confirmation  prompt 
Problem: Confirmation prompt incorrectly displayed after exiting the Spreadsheet Editor utility 
without making any changes. 

#31965 - Unable to update bulk element using Properties Editor 

Problem: The property editor controls were set to use current values from the ribbon, and it doesn't reflect the 
attributes of the selected elements. 

#32054 - Able to create two dynamic corridors 

Problem: Action called twice (overlapping). Each action creates temporary graphics which makes two corridors 
appear in the CAD window. 

#32069 - Unable to create mesh relimit 

Problem: The original mesh is already unloaded so the function fails when Apply is pressed a second time. 

#32348 - Synching issue with icon 

Problem: Synching issue with the Axes On/Off icon when opening a project using a session file that contained a 
CAD window. 

#32395 – Mesh file name displayed in lowercase 
Problem: Mesh name incorrectly displayed in lowercase after copying the mesh file. 

#32472 - Data grid display issue after resizing form 
Problem: Data grid does not expand after resizing the active form. 

#32514 - Suffix not added to mesh names 

Problem: Suffix not added to mesh names through Boolean » Intersect, Union, and Difference. Suffix field in 
the form should only visible when the boolean operation allows multi-mesh output.  
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#32578 - Plot Designer north arrow rotates in 3D when  using arcball rotation 

setting 

Problem: A flaw in north arrow's transform code calculated  the rotation based on the current matrix. 

#32173 – Display issue with StratModel Manager 

Problem: Column sizing and display issues when using the horizontal scrollbar and dragging it to the far right. 

32571 - Unexpected error when checking surfaces 

Problem: An unexpected error occurs when checking surfaces. 

#32579 – Mesh incorrectly coloured in resulting plot 

Problem: White coloured mesh displayed as black in resulting plot. 

#32582 – Graphical changes incorrectly committed 

Problem: Graphic changes committed by the Table Editor utility even when errors are present. 

#32622 – Save and restore formspec not mapping correctly 

Problem: Save and restore formspec not mapping correctly for washability CSV import. 

#32664 – MineScape crashes when deleting sequence data 

Problem: MineScape crashes after using the Delete All function to delete all sequence data. 

#32768 – Check desurvey fails when using specific data 

Problem: Check desurvey fails when using specific data. 

#32835 - Error when saving washability table 

Problem: Error when saving an edited washability table. 

#32905 – Element name not updated 

Problem: Upgrading a design file with multiple layers does not update the Element Name attribute. 

#32912 – Error with insert correlate 

Process: The Validate check box causes errors when the correlate insert process has not been committed. 

#32926 – Unable to create log plot file 

Problem: Unable to create log plot file. 

#32952 – MineScape crashes when saving an Excel file 

Problem: The Spreadsheet Editor utility crashes when trying to save an Excel file that is already open through 
an external application. 

#32953 – Compound not listed through StratModel Manager 

Problem: Compound is not listed through the Interval field of StratModel Manager. 
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#32954 – Custom colour still available 
Problem: Custom colour still listed even after it has been removed. 

#32956 Unable to update values 
Problem: Unable to update values when auditing is enabled. 

#32958 – Conflicting behaviour when pressing Space key 
Problem: Conflicting behaviour when pressing the Space key to toggle tooltip display. The Space key 
was being used by both Show/Hide Corridor (on the Slicing ribbon) and Toggle Tooltip (on the Bench 
Blocks ribbon). 

#32965 -  Extend to Boundary not working 

Problem: RapidCAD ‘s Extend to Boundary option not working as expected. 

#32967 – COGO manager does not disappear after drawing 

Problem: COGO manager does not disappear after completing a drawing operation. 

#32976 - Status prompt unclear  

Problem: The status prompt for the Surface Mesh »  Relimit option is unclear. Prompt now displays "Pick a 
polygon, Q to quit". 

#32977 – RapidCAD icon appears twice 
Problem: RapidCAD’s  green icon appears twice after quickly right-clicking on the purple dot icon. 

#32979 – Tooltip issue for triangle prisms 
Problem: Tooltip descriptions are empty for triangle prisms. 

#32984 – Data grid display issue after resizing form 
Problem: Data grid does not expand after resizing the active form. 

#32990 – Reserves report not producing output Excel file 

Problem: Unable to generate a reserves report through Excel when the TEMP variable has been set to a custom 
folder. 

#32991 – Error shown when solid creation is not completed in correct order 

Problem: A generic error message is displayed when engineering solid creation is not completed in the correct 
order. 

#33005 – MineScape crashes when refreshing viewport 
Problem: MineScape crashes when refreshing viewport. 

#33006 – MineScape crashes when clearing annotations 
Problem: MineScape crashes when trying to clear annotations. 

#33045 Module crashes when validating strip line for engineering solids 
Problem: SERVMESH module crashes when validating strip lines for engineering solid. 
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#33048 - Unable to open Plotspec file 
Problem: Plotspec with multiple features within one slot not supported. When converting plotspec to 
plot design, some viewport locations were incorrect.  

#33056 – Options not applied to StratModel contours 
Problem: The Filled, Lines , and Use Colour Palette options not implemented for the ‘Expression, 
‘Quality’, ‘Multi Model’, and ‘Multi Quality’ data source types. 

#33057 – Metadata deletion issue 
Problem: Metadata for other elements incorrectly updated after deleting a metadata key from a 
layer. 

#33075 – Continue Element not working 
Problem: RapidCAD’s Continue Element not working as expected. Intermittent issue where holding 
the left mouse button didn’t trigger the function. 

#33076 - First vertex automatically added when creating a line 
Problem: The first vertex is automatically added when creating a line using RapidCAD. The last 
detected point is incorrectly being used instead of the user input. 

#33099 – Mesh file name displayed in lowercase 
Problem: Mesh name incorrectly displayed in lowercase after renaming the mesh file. 

#33122 - Viewport information not listed through Properties Editor 
Problem: Properties for the active viewport are not updated through the Properties Editor.  

#33123 – Viewport value missing after switching between apps 
Problem: The Viewport value under the Display tab is empty after switching between CAD and Plot 
Designer. 

#33134 – Unable to access RapidCAD options 
Problem: Unable to access options via the green arrow icon after using RapidCAD’s Continue 
Element. 

#33137 – Active node for StratModel Manager 
Problem: The Model node is incorrectly set as the active node after building the table or grid through 
StratModel Manager. 

#33141 - SQL Server password policy issue 
Problem: SQL Server honours the Microsoft Windows password policy by default, meaning the default GDB 

login password ("gdb") is rejected on some PCs 

#33178 – MineScape crashes when creating a mesh file 
Problem:  MineScape crashes due to an unhandled attribute value within the Vulcan import file. 

#33179 - Properties Editor does not update 
Problem: The Properties Editor does not update while the Edit Annotation form is displayed. 
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#33176 – Incorrect triangle output when using offset values 

Problem: Incorrect triangle output when using offset values. Missing links in the wireframe created through 
Utilities » Drives. 

#33251 – Invalid output produced through Merge DTM 

Problem: Invalid output produced through Merge DTM. 

#33254 - 2D Graphics not displaying correlation and error message 

Problems:  2D graphic not displaying correlation: In some cases,  the DEDERIVE or NOHOLESELECT error is 
displayed. Graphics occasionally not drawn properly, for example, no correlation or no intervals. 

If grid value is set, but the display definition is empty, SERVORAMPL will display the ”Converting string yellow 
to an integer. Invalid character """ in name " error message. 

#33255 – Commit does not commit the changes 

Problem: Unable to commit graphical changes. 

#33265 -Large coordinates warning 

Problem: Large coordinates warning is displayed when performing a CAD operation. 

#33286 - StratModel Cross Section Form Issue 

Problem: Right-click Row » Fill Down and Pick options are not updating the selected control as expected. After 
reopening the form, fields are also not populated by the proper formspec values from the previous instance. 

#33320 – Reset/Replace empty interval 

Problem: Interval not listed in the interval list. Reset/replace to empty interval displays the "X152: Interval not 
in the interval list" error message. 

#33321 - Properties Editor doesn’t retain values after zooming or panning 

Problem: When multiple elements are selected, zooming, or panning  in the viewport incorrectly replaces the 
selection set properties with the viewport properties. 

#33326 - Create solid issue when using specific data 

Problem: Issue in the projection result,  the tag definition on the projected boundary is different from the 
original polygon. 

#33350 – Error message about an incorrect password, but database creation 

continues 

Problem: The GDB password not sent correctly causing an error message regarding an incorrect password. 
Database is created despite error message. 

#33353 – Unable to list database names 

Problem: Unable to list database names when using a non-admin user. 
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#33359 - Clear option missing for the Attribute Display Definition form 

Problem: The Clear right-click menu option is missing for the Text Display Definition field on the Attribute 
Display Definition form. 

#33376 – Unable to delete user role 

Problem: Unable to delete a user role via the Delete button when using an SQL database. 

#33384 – North arrow container aspect ratio and scale not working 

Problem : The Keep Aspect Ratio and Image Scale options for north arrow containers not working as expected. 

#33387 – Synch issue with check box state 

Problem: Group check box not responsive after  the resulting mesh was recalculated. 

#33398 – MineScape crashes after removing custom colours 

Problem: MineScape crashes after removing custom colours. 

#33410 – Performance issue when deleting large number of mesh files 

Problem: MineScape slow to respond after deleting 300+ mesh files. 

#33417 – Incorrect mesh output 

Problem: Incorrect mesh output when using the Delete Outside option with boundary polygons that intersect. 

#33419 – Unable to import mesh data from GoCAD Triangulated Surface files 

Problem: Unable to import mesh data from GoCAD Triangulated Surface files 

#33425 - Warning message displayed when importing DXF/DWG files 

Problem: A warning message is displayed when creating a mesh file from a DXF/DWG file. 

#33433 – Incorrect mesh output after dragging and dropping images 

Problem: Incorrect mesh output produced after dragging and dropping image files into the CAD window. 

#33435-  Unable to locate input files when importing Datamine files 

Problem: Unable to locate input files when creating a mesh file from Datamine files. 

#33438 – Mesh output incorrect 

Problem: Incorrect mesh output produced when using Create From Surface. 

#33442 – Incorrect total values in reserve report 

Problem: Incorrect subtotal and total average values in resulting StratModel reserve report. 



 Release Notes 

 

98 
 

#33444 – New mesh files not listed in alphabetical order 

Problem: New mesh files are not listed in alphabetical order after being created. 

#33448 – Mesh file not automatically displayed after import 

Problem: Imported mesh files are not automatically displayed when using the Display After Import check box. 

#33461 – Database connection name incorrect 

Problem: Database name being used instead of connection name. 

#33463 – MPL scripts not working 

Problem: Unable to successfully run MPL scripts that use the FENCERECTANGLE verb. Script files work in an 
earlier version of MineScape. 

 

MineScape Help 
Help » Help Location » Offline 
A new MineScape 2021 offline help installer has been uploaded to the MineScape software distribution portal. 
An existing MineScape 2021 help installation must be removed prior to installing the updated MineScape 2021 
help. 

Help » Help Location » Online 
Content stored on the official MineScape help server is updated automatically to reflect the changes 
introduced through each MineScape 2021 Update. 


